[GitHub] geronimo-specs pull request #6: GERONIMO-6560 JSON spec jar is not able to l...

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[GitHub] geronimo-specs pull request #6: GERONIMO-6560 JSON spec jar is not able to l...

stefanseifert
GitHub user stefanseifert opened a pull request:

    https://github.com/apache/geronimo-specs/pull/6

    GERONIMO-6560 JSON spec jar is not able to load provider in an OSGi environment

   

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/stefanseifert/geronimo-specs feature/GERONIMO-6560-json-osgi-serviceloader

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/geronimo-specs/pull/6.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #6
   
----
commit af5b9c47a7ba03a8cc1b824af5949411eac54943
Author: sseifert <[hidden email]>
Date:   2017-03-13T10:09:26Z

    GERONIMO-6560 add Require-Capability header for OSGi ServiceLoader support

commit 04aef91eae1edd266ef4150bdd38f52e2ade3ccc
Author: sseifert <[hidden email]>
Date:   2017-03-13T10:23:15Z

    GERONIMO-6560 switch to ServiceLoader implementation instead of parsing META-INF/services/ files manually
    remove reflection-based OSGi support code which did not work anyway

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at [hidden email] or file a JIRA ticket
with INFRA.
---