OpenAPI jackson dependency

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenAPI jackson dependency

Romain Manni-Bucau
Hi guys,

A user reported the requirement of jackson in current code (thanks lambdas :() whereas it is not needed in most of the cases.
I fixed it on master (https://issues.apache.org/jira/browse/GERONIMO-6611) and wonder if we want to release an opanapi 1.0.1 shortly with this fix.

wdyt?

Romain Manni-Bucau
@rmannibucau |  Blog | Old BlogGithub | LinkedIn | Book
Reply | Threaded
Open this post in threaded view
|

Re: OpenAPI jackson dependency

jlmonteiro
If it's not required and causing problems, I'd say yes.
Especially because you already fixed it



Le ven. 27 juil. 2018 à 17:31, Romain Manni-Bucau <[hidden email]> a écrit :
Hi guys,

A user reported the requirement of jackson in current code (thanks lambdas :() whereas it is not needed in most of the cases.
I fixed it on master (https://issues.apache.org/jira/browse/GERONIMO-6611) and wonder if we want to release an opanapi 1.0.1 shortly with this fix.

wdyt?

Romain Manni-Bucau
@rmannibucau |  Blog | Old BlogGithub | LinkedIn | Book
Reply | Threaded
Open this post in threaded view
|

Re: OpenAPI jackson dependency

Mark Struberg
+1

LieGrue,
strub

> Am 27.07.2018 um 20:01 schrieb Jean-Louis MONTEIRO <[hidden email]>:
>
> If it's not required and causing problems, I'd say yes.
> Especially because you already fixed it
>
>
>
> Le ven. 27 juil. 2018 à 17:31, Romain Manni-Bucau <[hidden email]> a écrit :
> Hi guys,
>
> A user reported the requirement of jackson in current code (thanks lambdas :() whereas it is not needed in most of the cases.
> I fixed it on master (https://issues.apache.org/jira/browse/GERONIMO-6611) and wonder if we want to release an opanapi 1.0.1 shortly with this fix.
>
> wdyt?
>
> Romain Manni-Bucau
> @rmannibucau |  Blog | Old Blog | Github | LinkedIn | Book

Reply | Threaded
Open this post in threaded view
|

Re: OpenAPI jackson dependency

Romain Manni-Bucau
Vote sent :)

Romain Manni-Bucau
@rmannibucau |  Blog | Old BlogGithub | LinkedIn | Book


Le sam. 28 juil. 2018 à 09:35, Mark Struberg <[hidden email]> a écrit :
+1

LieGrue,
strub

> Am 27.07.2018 um 20:01 schrieb Jean-Louis MONTEIRO <[hidden email]>:
>
> If it's not required and causing problems, I'd say yes.
> Especially because you already fixed it
>
>
>
> Le ven. 27 juil. 2018 à 17:31, Romain Manni-Bucau <[hidden email]> a écrit :
> Hi guys,
>
> A user reported the requirement of jackson in current code (thanks lambdas :() whereas it is not needed in most of the cases.
> I fixed it on master (https://issues.apache.org/jira/browse/GERONIMO-6611) and wonder if we want to release an opanapi 1.0.1 shortly with this fix.
>
> wdyt?
>
> Romain Manni-Bucau
> @rmannibucau |  Blog | Old Blog | Github | LinkedIn | Book