Re: svn commit: r191366 - in /geronimo/trunk/modules/interop: ./ src/java/org/apache/geronimo/interop/generator/ src/java/org/apache/geronimo/interop/rmi/iiop/portable/ src/test-data/ src/test-data/META-INF/ src/test-resources/

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: svn commit: r191366 - in /geronimo/trunk/modules/interop: ./ src/java/org/apache/geronimo/interop/generator/ src/java/org/apache/geronimo/interop/rmi/iiop/portable/ src/test-data/ src/test-data/META-INF/ src/test-resources/

Jacek Laskowski-5
[hidden email] wrote:

> Author: dain
> Date: Sun Jun 19 15:25:18 2005
> New Revision: 191366
>
> URL: http://svn.apache.org/viewcvs?rev=191366&view=rev
> Log:
> Added portable stub generator
> PortableStubCompiler contains utility methods to mangle overloaded operation names
> Added name manger tests
>
> Added:
>     geronimo/trunk/modules/interop/src/java/org/apache/geronimo/interop/rmi/iiop/portable/
>     geronimo/trunk/modules/interop/src/java/org/apache/geronimo/interop/rmi/iiop/portable/IiopOperation.java

Didn't we decide that abbreviations are written all in uppercase? If so,
shouldn't IiopOperation become IIOPOperation?

Jacek


Reply | Threaded
Open this post in threaded view
|

Re: svn commit: r191366 - in /geronimo/trunk/modules/interop: ./ src/java/org/apache/geronimo/interop/generator/ src/java/org/apache/geronimo/interop/rmi/iiop/portable/ src/test-data/ src/test-data/META-INF/ src/test-resources/

Dain Sundstrom
On Jun 19, 2005, at 3:44 PM, Jacek Laskowski wrote:

> [hidden email] wrote:
>
>> Author: dain
>> Date: Sun Jun 19 15:25:18 2005
>> New Revision: 191366
>> URL: http://svn.apache.org/viewcvs?rev=191366&view=rev
>> Log:
>> Added portable stub generator
>> PortableStubCompiler contains utility methods to mangle overloaded  
>> operation names
>> Added name manger tests
>> Added:
>>     geronimo/trunk/modules/interop/src/java/org/apache/geronimo/
>> interop/rmi/iiop/portable/
>>     geronimo/trunk/modules/interop/src/java/org/apache/geronimo/
>> interop/rmi/iiop/portable/IiopOperation.java
>>
>
> Didn't we decide that abbreviations are written all in uppercase?  
> If so, shouldn't IiopOperation become IIOPOperation?

I don't remember, but I hope we don't keep that decision.  All  
uppercase abbrevations are quite difficult to read expecially when  
you have them one after another EJBIIOPGBean.  Also they make really  
ugly names when standard JavaBeans rules are applied eJBIIOPGBean or  
ejbiiopgBean.

-dain