[jira] [Commented] (GERONIMO-6246) remove package versions from most spec jars until there's an osgi recommendation on what they should be.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (GERONIMO-6246) remove package versions from most spec jars until there's an osgi recommendation on what they should be.

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/GERONIMO-6246?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16593813#comment-16593813 ]

David Jencks commented on GERONIMO-6246:
----------------------------------------

In case you meant to ask me, I think we can resolve this.

> remove package versions from most spec jars until there's an osgi recommendation on what they should be.
> --------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMO-6246
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-6246
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues)
>          Components: specs
>    Affects Versions: 3.0.0
>            Reporter: David Jencks
>            Priority: Major
>             Fix For: 3.0.2
>
>
> except maybe for servlet, there aren't any osgi recommendations for package versions of spec api packages.  We will just cause incompatibility and confusion if we decide on our own what the versions should be.  This has already happened with our use of 3.0 for the servlet 3.0 package versions, whereas everyone seems to agree it should be 2.6 (and this should be checked.... maybe some packages haven't changed from 2.5).
> This will require recompiling all bundles that have been compiled against our specs.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)