[jira] [Commented] (GERONIMO-6604) Geronimo JWT Auth uses CDI 2.0 (must be 1.2)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (GERONIMO-6604) Geronimo JWT Auth uses CDI 2.0 (must be 1.2)

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/GERONIMO-6604?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16447668#comment-16447668 ]

Rudy De Busscher commented on GERONIMO-6604:
--------------------------------------------

I find the spec text ambiguous

Within the specification ([https://github.com/eclipse/microprofile-bom/releases/download/1.3/microprofile-spec-1.3.pdf)] the following is noted

 
{code:java}
MicroProfile applications that make use of APIs or versions not mentioned below are not considered portable.
• Java SE 8
• CDI (Contexts and Dependency Injection for Java EE) 1.2
{code}
 
meaning that an application build with Geronimo JWT Auth is considered as not portable when it is based on CDI 2.0?

 

I'll create a PR

 

Thx

Rudy

> Geronimo JWT Auth uses CDI 2.0 (must be 1.2)
> --------------------------------------------
>
>                 Key: GERONIMO-6604
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-6604
>             Project: Geronimo
>          Issue Type: Wish
>      Security Level: public(Regular issues)
>            Reporter: Rudy De Busscher
>            Priority: Major
>
> When adding the 
> {code:java}
> geronimo-jwt-auth-impl{code}
> to WildFLy 10.x, the 
> {code:java}
> GeronimoJwtAuthExtension{code}
> is not executed due to the fact is makes references to CDI 2.0.
>  
> Microprofile depends on CDI 1.2, so using 2.0 is wrong.
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)