[jira] [Commented] (XBEAN-287) OSGi metadata should include Spring 4.X as a valid version

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (XBEAN-287) OSGi metadata should include Spring 4.X as a valid version

Romain Manni-Bucau (Jira)

    [ https://issues.apache.org/jira/browse/XBEAN-287?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15006805#comment-15006805 ]

Tom De Wolf commented on XBEAN-287:
-----------------------------------

Any idea when this pull request and a release of version 4.5 is planned? It would be great if this can be done as soon as possible to help use with an upgrade path we are trying to push through to Spring 4.x of our application.

> OSGi metadata should include Spring 4.X as a valid version
> ----------------------------------------------------------
>
>                 Key: XBEAN-287
>                 URL: https://issues.apache.org/jira/browse/XBEAN-287
>             Project: XBean
>          Issue Type: Bug
>          Components: spring
>    Affects Versions: 3.16
>            Reporter: Seth Leger
>            Priority: Critical
>              Labels: patch
>
> Spring 4.X is available as OSGi bundles from Apache ServiceMix and since I believe that XBean is compatible with Spring 4, it should be included in the OSGi Import-Package directive.
> I have submitted this change as a pull request to the Geronimo XBean github mirror: https://github.com/apache/geronimo-xbean/pull/11



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)