[jira] [Commented] (XBEAN-287) OSGi metadata should include Spring 4.X as a valid version

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (XBEAN-287) OSGi metadata should include Spring 4.X as a valid version

Romain Manni-Bucau (Jira)

    [ https://issues.apache.org/jira/browse/XBEAN-287?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15341661#comment-15341661 ]

Christopher L. Shannon commented on XBEAN-287:
----------------------------------------------

Would it be possible to get this merged soon and a new release?  This is an issue for ActiveMQ with trying to support Spring 4.x and OSGi.

> OSGi metadata should include Spring 4.X as a valid version
> ----------------------------------------------------------
>
>                 Key: XBEAN-287
>                 URL: https://issues.apache.org/jira/browse/XBEAN-287
>             Project: XBean
>          Issue Type: Bug
>          Components: spring
>    Affects Versions: 3.16
>            Reporter: Seth Leger
>            Priority: Critical
>              Labels: patch
>
> Spring 4.X is available as OSGi bundles from Apache ServiceMix and since I believe that XBean is compatible with Spring 4, it should be included in the OSGi Import-Package directive.
> I have submitted this change as a pull request to the Geronimo XBean github mirror: https://github.com/apache/geronimo-xbean/pull/11



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)