[jira] Resolved: (GERONIMO-442) Demo module isn't started properly

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] Resolved: (GERONIMO-442) Demo module isn't started properly

Development mailing list
     [ http://issues.apache.org/jira/browse/GERONIMO-442?page=all ]
     
Aaron Mulder resolved GERONIMO-442:
-----------------------------------

    Fix Version: 1.0-M4
     Resolution: Fixed

Probably caused because o/a/g/Demo depended on o/a/g/Secure and the latter was not automatically started when the former was.  If that's right, it was fixed in 216276.

In any case, the Demo module now starts and shows up as running.

> Demo module isn't started properly
> ----------------------------------
>
>          Key: GERONIMO-442
>          URL: http://issues.apache.org/jira/browse/GERONIMO-442
>      Project: Geronimo
>         Type: Bug
>   Components: deployment
>     Versions: 1.0-M2
>     Reporter: Aaron Mulder
>      Fix For: 1.0-M4

>
> When you issue a JSR-88 "start" command on module "org/apache/geronimo/Demo", the server reports that it's starting the configuration, and the ProgressObject returns success and returns the TargetModuleID for the affected configuration.
> However, org/apache/geronimo/Demo still shows up in the stopped module list.
> It appears to actually be running, though -- if you stop it once it stops, and if you stop it again it fails with a NoSuchConfigException.  Likewise if you try to start it twice the second time fails.
> It seems the bug is in how the started/stopped list is generated, though a module such as org/apache/geronimo/SystemJMS (or o/a/g/DefaultDatabase) can be stopped and started successfully.  Might be specific to web apps?

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira