[jira] [Updated] (GERONIMO-6604) Geronimo JWT Auth uses CDI 2.0 (must be 1.2)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Updated] (GERONIMO-6604) Geronimo JWT Auth uses CDI 2.0 (must be 1.2)

JIRA jira@apache.org

     [ https://issues.apache.org/jira/browse/GERONIMO-6604?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Romain Manni-Bucau updated GERONIMO-6604:
-----------------------------------------
    Issue Type: Wish  (was: Bug)

> Geronimo JWT Auth uses CDI 2.0 (must be 1.2)
> --------------------------------------------
>
>                 Key: GERONIMO-6604
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-6604
>             Project: Geronimo
>          Issue Type: Wish
>      Security Level: public(Regular issues)
>            Reporter: Rudy De Busscher
>            Priority: Major
>
> When adding the 
> {code:java}
> geronimo-jwt-auth-impl{code}
> to WildFLy 10.x, the 
> {code:java}
> GeronimoJwtAuthExtension{code}
> is not executed due to the fact is makes references to CDI 2.0.
>  
> Microprofile depends on CDI 1.2, so using 2.0 is wrong.
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)